import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^a-zA-Z\\d])?(?P<file_id>[\\-a-zA-Z]{3}[\\-a-zA-Z\\d]{5,15}H?)([^a-zA-Z\\d].*)?\\.(?P<file_ext>mov|mpg|mxf|mp4)$";
final String string = "GOOG6998000H.mov";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}