// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:[\w-]\.?)+)@((?:[\w-]+\.)+)([A-Za-z]{2,4})").unwrap();
let string = "donkey.kong@kart.com.br
bowser1@games.info
super-mario@nintendo.JP
TEAM.donkey-kong@MARIO.kart1.nintendo.com
toad@kart...com
wario@kart@nintendo.com
yoshi@nintendo
daisy@nintendo.b
..@email.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}