# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\n]*\s+)(?<g2>Added|Modified|Normal)\s+\((?<g3>\S+\s+only)\)\s*$"
test_str = ("opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/ClasspathResourceFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/RbacFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/StructureDefinitionFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/LuceneFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/DeploymentFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/OpenEJBFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/fixture/ProcessDefinitionFixture.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/builder/StructureInstanceExternalBuilderTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/builder/JsonStructureBuilderTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/builder/JsonDataTreeBuilderTest.java Deleted (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceCompositionTest.java Added (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/PermissionServiceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/JbpmJobServiceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceAddReferenceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceRbacTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/DeploymentResourceServiceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceRemoveReferenceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceBackReferenceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/StructureServiceLogTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/service/FinderServiceTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/mittlerservice/StructureServiceRemoteSearchTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/lucene/structure/LuceneStructureIndexerRandomTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/lucene/LuceneSearcherTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/lucene/LuceneIndexerTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/actionhandler/CancelAllTimerActionHandlerTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/actionhandler/AutoStartActionHandlerTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/java/de/esn/opusp/jbpm3/actionhandler/BirtRenderActionHandlerTest.java Modified (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStart Test/process/processimage.jpg Added (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStart Test/process/processdefinition.xml Added (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStart Test/process/gpd.xml Added (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStart Test/process Added (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStart Test Added (content only)\n"
"opusp-jbpm3/src/test/resources/CancellAllTimerActionHandler Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStartTest/process/processimage.jpg Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStartTest/process/processdefinition.xml Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStartTest/process/gpd.xml Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStartTest/process Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/AutoStartTest Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/process/gpd.xml Added (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/process/processimage.jpg Added (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/process/processdefinition.xml Added (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/process Added (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/cancell/processimage.jpg Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/cancell/processdefinition.xml Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/cancell/gpd.xml Deleted (content only)\n"
"opusp-jbpm3/src/test/resources/CancelAllTimerActionHandler/cancell Deleted (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/cluster/ClusterSingletonServiceImpl.java Added (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/cluster/ClusterSingletonChannelActivator.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/builder/DataTreeBuilder.java Deleted (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/builder/JsonStructureBuilder.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/builder/JsonDataTreeBuilder.java Deleted (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/builder/StructureExternalBuilder.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/model/appview/DataTree.java Deleted (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/model/appview Deleted (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/ExtStateServiceImpl.java Added (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/ClusterSingletonServiceImpl.java Deleted (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/StructureRuleService.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/RbacServiceImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/OpuspStructureConverter.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/StructureFieldService.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/JbpmJobServiceImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/OpuspCommandServiceBeanImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/StructureServiceImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/StructureInstanceLoader.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/DeploymentResourceServiceImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/service/MenuConfigServiceImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/utils/JsUtil.java Added (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/cache/structure/StructureCacheImpl.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/lucene/TypedQueryParser.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/lucene/ParseTools.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/entity/OpuspExtState.java Added (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/entity/structure/instance/OpuspInstance.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/entity/structure/definition/OpuspReference.java Modified (content only)\n"
"opusp-jbpm3/src/main/java/de/esn/opusp/jbpm3/entity/structure/definition/OpuspAttribute.java Modified (content only)\n"
"opusp-jbpm3/src/main/resources/ext/StateProviderTemplate.js Added (content only)\n"
"opusp-jbpm3/src/main/resources/ext Added (content only)\n"
"opusp-jbpm3/src/main/resources/dataview/structure/structure-lib.js Modified (content only)\n"
"opusp-jbpm3/src/main/resources/dataview/structure/multiview.js Modified (content only)\n"
"opusp-jbpm3/src/main/resources/dataview/structure/single-index.html Modified (content only)\n"
"opusp-jbpm3/src/main/resources/dataview/appview/appview-lib.js Deleted (content only)\n"
"opusp-jbpm3/src/main/resources/dataview/appview/index.html Deleted (content only)\n"
"opusp-jbpm3/src/main/resources/dataview/appview Deleted (content only)\n"
"opusp-jbpm3/pom.xml Modified (content only)\n"
"opusp-jbpm3 Normal (properties only)\n"
"opusp-rest/src/test/java/de/esn/opusp/rest/service/ExportServiceRESTTest.java Modified (content only)\n"
"opusp-rest/src/test/java/de/esn/opusp/rest/utils/FieldsConverterTest.java Modified (content only)\n"
"opusp-rest/src/test/java/de/esn/opusp/rest/fixture/MockStructureServiceImpl.java Modified (content only)\n"
"opusp-rest/src/test/java/de/esn/opusp/rest/fixture/StructureServiceAdapter.java Modified (content only)\n"
"opusp-rest/src/main/java/de/esn/opusp/rest/model/structure/export/Attribute.java Modified (content only)\n"
"opusp-rest/src/main/java/de/esn/opusp/rest/service/ExtStateServiceREST.java Added (content only)\n"
"opusp-rest/src/main/java/de/esn/opusp/rest/service/StructureServiceREST.java Modified (content only)\n"
"opusp-rest/src/main/java/de/esn/opusp/rest/utils/FieldsConverter.java Modified (content only)\n"
"opusp-rest/src/main/java/de/esn/opusp/rest/structureimport/ImportHandler.java Modified (content only)\n"
"opusp-rest/pom.xml Modified (content only)\n"
"opusp-rest Normal (properties only)\n"
"opusp-web/src/test/java/de/esn/opusp/web/server/fixture/MockStructureServiceImpl.java Modified (content only)\n"
"opusp-web/src/test/java/de/esn/opusp/web/server/fixture/StructureServiceAdapter.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/server/admin/OpuspStructureConverter.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/server/admin/AdminServiceImpl.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/server/MenuConfigServiceImpl.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/data/model/DataTreeRefreshCallback.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/data/model/DataModel.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/data/DataController.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/GWTConstants.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/model/structure/StructureTreeEntry.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/model/structure/StructureModel.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/model/structure/OpuspReference.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/model/structure/OpuspStructure.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/model/structure/OpuspAttribute.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/model/structure/AdminStructureModel.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/AttributeListPanel.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/StructureTreePanel.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/ResourceAttributeWindow.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/StructureWindow.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/ReferenceAttributeWindow.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/AttributeWindow.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/structure/KatalogAttributeWindow.java Modified (content only)\n"
"opusp-web/src/main/java/de/esn/opusp/web/client/admin/AdminController.java Modified (content only)\n"
"opusp-web/src/main/resources/de/esn/opusp/web/public/Application.css Modified (content only)\n"
"opusp-web/src/main/resources/de/esn/opusp/web/public/icons/attribute_reference_composition_many_deleted.png Added (content only)\n"
"opusp-web/src/main/resources/de/esn/opusp/web/public/icons/attribute_reference_composition_many.png Added (content only)\n"
"opusp-web/src/main/resources/de/esn/opusp/web/public/icons/attribute_reference_composition_one_deleted.png Added (content only)\n"
"opusp-web/src/main/resources/de/esn/opusp/web/public/icons/attribute_reference_composition_one.png Added (content only)\n"
"opusp-web/pom.xml Modified (content only)\n"
"opusp-web Normal (properties only)\n"
"opusp-test/pom.xml Modified (content only)\n"
"opusp-test Normal (properties only)\n"
"opusp-app/pom.xml Modified (content only)\n"
"opusp-app Normal (properties only)\n"
"opusp-selenium/pom.xml Modified (content only)\n"
"opusp-selenium Normal (properties only)\n"
"pom.xml Modified (content only)\n"
"opusp-core/pom.xml Modified (content only)\n"
"opusp-core Normal (properties only)\n"
"opusp-common/pom.xml Modified (content only)\n"
"opusp-common Normal (properties only)\n"
"opusp-service/pom.xml Modified (content only)\n"
"opusp-service Normal (properties only)\n"
"opusp-script/src/main/resources/sql/create/mssql/opusp.extra.mssql.3.18.10.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mssql/opusp.extra.mssql.3.18.12.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mssql/opusp.extra.mssql.3.18.9.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mssql/opusp.extra.mssql.3.18.11.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mssql/opusp.extra.mssql.3.18.8.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mssql/opusp.extra.mssql._VERSION_.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/create/mysql/opusp.extra.mysql.3.18.11.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mysql/opusp.extra.mysql.3.18.8.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mysql/opusp.extra.mysql.3.18.10.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mysql/opusp.extra.mysql.3.18.12.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mysql/opusp.extra.mysql.3.18.9.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/mysql/opusp.extra.mysql._VERSION_.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/create/oracle/opusp.extra.oracle.3.18.9.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/oracle/opusp.extra.oracle.3.18.11.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/oracle/opusp.extra.oracle.3.18.8.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/oracle/opusp.extra.oracle.3.18.10.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/oracle/opusp.extra.oracle.3.18.12.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/create/oracle/opusp.extra.oracle._VERSION_.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/create/jbpm-3.2.6.SP1/jbpm.jpdl.mysql.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/create/jbpm-3.2.6.SP1/jbpm.jpdl.oracle.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/create/jbpm-3.2.6.SP1/jbpm.jpdl.mssql.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mssql/opusp.extra.mssql.3.18.6-3.18.8.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mssql/opusp.extra.mssql.3.18.8-3.18.9.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mssql/opusp.extra.mssql.3.18.9-3.18.10.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mssql/opusp.extra.mssql.3.18.10-3.18.11.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mssql/opusp.extra.mssql.3.18.11-3.18.12.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mssql/opusp.extra.mssql._VERSIONRANGE_.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mysql/opusp.extra.mysql.3.18.10-3.18.11.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mysql/opusp.extra.mysql.3.18.11-3.18.12.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mysql/opusp.extra.mysql.3.18.8-3.18.9.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mysql/opusp.extra.mysql.3.18.6-3.18.8.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mysql/opusp.extra.mysql.3.18.9-3.18.10.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/mysql/opusp.extra.mysql._VERSIONRANGE_.sql Modified (content only)\n"
"opusp-script/src/main/resources/sql/migrate/oracle/opusp.extra.oracle.3.18.6-3.18.8.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/oracle/opusp.extra.oracle.3.18.9-3.18.10.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/oracle/opusp.extra.oracle.3.18.10-3.18.11.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/oracle/opusp.extra.oracle.3.18.11-3.18.12.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/oracle/opusp.extra.oracle.3.18.8-3.18.9.sql Added (content only)\n"
"opusp-script/src/main/resources/sql/migrate/oracle/opusp.extra.oracle._VERSIONRANGE_.sql Modified (content only)\n"
"opusp-script/pom.xml Modified (content only)\n"
"opusp-script Normal (properties only)\n"
"opusp-config/pom.xml Modified (content only)\n"
"opusp-config Normal (properties only)\n"
"opusp-local-client/pom.xml Modified (content only)\n"
"opusp-local-client Normal (properties only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/model/OpuspExtState.java Added (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/model/structure/definition/OpuspReference.java Modified (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/model/structure/definition/OpuspAttribute.java Modified (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/model/structure/transport/Attribute.java Modified (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/model/structure/transport/Field.java Modified (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/model/MenuConfig.java Modified (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/service/ExtStateService.java Added (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/service/StructureService.java Modified (content only)\n"
"opusp-api/src/main/java/de/esn/opusp/api/remote/StructureServiceRemote.java Modified (content only)\n"
"opusp-api/pom.xml Modified (content only)\n"
"opusp-api Normal (properties only)\n"
" Normal (properties only)\n")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.