$re = '/((?=(leaf)|(gutter)))\w+/i';
$str = 'Special 20% off LeafFilter gutter offer!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);