#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?:[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-]|[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-](?:[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-]|\.(?!\.)){0,62}[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-])@(?:[\p{L}\p{M}\p{N}]|[\p{L}\p{M}\p{N}][\p{L}\p{M}\p{N}_-]{0,61}[\p{L}\p{M}\p{N}])(?:\.(?:[\p{L}\p{M}\p{N}]|[\p{L}\p{M}\p{N}][\p{L}\p{M}\p{N}_-]{0,61}[\p{L}\p{M}\p{N}]))+\.?$"
Local $sString = "VALID_SUPPORTED" & @CRLF & _
"" & @CRLF & _
"-hello@world.co" & @CRLF & _
"hello.world@co.co" & @CRLF & _
"simple@example.com" & @CRLF & _
"underscore@in_domain.net" & @CRLF & _
"simple@example.com." & @CRLF & _
"very.common@example.com" & @CRLF & _
"संपर्क@डाटामेल.भारत" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"медведь@с-балалайкой.рф" & @CRLF & _
"other.email-with-hyphen@example.com" & @CRLF & _
"fully-qualified-domain@example.com." & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"Pelé@example.com" & @CRLF & _
"x@example.com" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"test/test@test.com" & @CRLF & _
"böb@example.com" & @CRLF & _
"BÖB@gmail.com" & @CRLF & _
"example@s.example" & @CRLF & _
"mailhost!username@example.org" & @CRLF & _
"user%example.com@example.org" & @CRLF & _
"user-@example.org" & @CRLF & _
"20401@some.email" & @CRLF & _
"" & @CRLF & _
"MAYBE_VALID_MAYBE_SUPPORTED" & @CRLF & _
"" & @CRLF & _
"domain.end.with.nums@no.good.127" & @CRLF & _
"mason@日本.com" & @CRLF & _
"user@example.😀" & @CRLF & _
"☹️@hello.world" & @CRLF & _
"" & @CRLF & _
"VALID_UNSUPPORTED" & @CRLF & _
"" & @CRLF & _
"hns@neel" & @CRLF & _
"admin@mailserver1" & @CRLF & _
"" "@example.org" & @CRLF & _
""john..doe"@example.org" & @CRLF & _
""very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com" & @CRLF & _
"postmaster@[123.123.123.123]" & @CRLF & _
"postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]" & @CRLF & _
"" & @CRLF & _
"INVALID" & @CRLF & _
"" & @CRLF & _
"hello..world@co.co" & @CRLF & _
"hello@world-.co" & @CRLF & _
"hello@.world.co" & @CRLF & _
"Abc.example.com" & @CRLF & _
"A@b@c@example.com" & @CRLF & _
"a"b(c)d,e:f;g<h>i[j\k]l@example.com" & @CRLF & _
"just"not"right@example.com" & @CRLF & _
"this is"not\allowed@example.com" & @CRLF & _
"this\ still\"not\\allowed@example.com" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com" & @CRLF & _
"i_like_underscore@but_its_not_allowed_in_this_part.example.com" & @CRLF & _
"QA[icon]CHOCOLATE[icon]@test.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")