// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)Иванов[\s,а,у,ым,е,ой,]{0,2}[\s]+А.*").unwrap();
let string = " 1.noant 2.vonrainman 3.YuriiKyiv 4.jbstudio 5.pitt56 6.Practice Makes Perfect 7.Dima_1st 8.daneel 9.ivanoff88 10.Eldram 11.serg_vn 12.sasha30 13.Chidori 14.iMrHyde ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}