use strict;
my $str = '6x7 456 78993 45528 8382 837372 82 128 8282 82 828282 28 8282635372892 838
Lorem ipsum dolor 335-5555555 sit amet, consectetur adipisci5555555555 elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid e Mario ROSSI x ea commodi Fabio DE LUIGI consequatur. 3835555555 Quis aute iure reprehenderit in voluptate 555/555555velit esse cillum dolore eu fugiat nulla pariatur. 43434734 343 3 464 56 5 65 6 5 757 676 Microsoft Office.
Excepteur sint Vaalima obcaecat Digital Forensics cupiditat non RSSNDR74D04A271P proident, sunt in culpa qui officia deserunt mollit anim id est laborum. Lorem ipsum Dr.Torsby dolor sit amet, consec 234 546 367 2789 Veldrin tetur adipisci elit,347/5555555 sed eiusm 565437 od tempor incidunt ut labore et Andrea dolore magna aliqua. Ut enim ad minim TELEFUNKEN
FRODENO Jan enim ad minim 555-555555veniam, quis rssndr74d04a271u Zhang YUNING nostrum exercitationem ullam corporis suscip Wu LEI it laboriosam, nisi ut aliquid ex ea commodi Arael consequatur. Quis aute iure r328 5555555 eprehenderit in volup6767676767 6767676767tate 555 555555velit PLANESCAPE esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint obcae67676767676767676cat Marco D\'AMBROSIO rssndr74D04A271U cupidita34567893 t non proident, sunt in culpa qui officia deserunt mollit Abdul-Wahaab RAHMAN anim id est laborum. 388.555555 Lorem rSsndr74d04a271u ipsum dolor sit amet, consectetur adipisci elit, sed Rosa eiusmod tempor Aimar incidunt ut labore et dolore magna a6767676767 32252525 353535 5353535liqua. Ut enim ad minim';
my $regex = qr/([A-Z]{1}[[:lower:]]+( |-)([A-Z]{1}[[:lower:]]+ )*[A-Z]+( |')[A-Z]*)|([A-Z]+( |')[A-Z]*[A-Z]{1}[[:lower:]]+( |-)([A-Z]{1}[[:lower:]]+)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}