package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|[12]\d|3[01])(0[1-9]|1[0-2])\d{2}[-]?\d{4}$`)
var str = `310255-5253`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}