// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?P<fname>[A-Za-zåé]+ ?[A-Za-zåé]+\.? ?)+ (?P<lname>[A-Za-zåé]+\.? ?))(?:(?:\d+,)+ ?)?").unwrap();
let string = "Frank Kreienkamp1, Sjoukje Y. Philip2, Jordis S. Tradowsky1,4, Sarah F. Kew2, Philip Lorenz1, Julie Arrighi7,8,9, Alexandre Belleflamme16, Thomas Bettmann18, Steven Caluwaerts13,19, Steven C. Chan14, Andrew Ciavarella22, Lesley De Cruz13, Hylke de Vries2, Norbert Demuth18, Andrew Ferrone17, Erich M. Fischer6, Hayley J. Fowler14, Klaus Goergen16, Dorothy Heinrich7, Yvonne Henrichs18, Geert Lenderink2, Frank Kaspar10, Enno Nilson15, Friederike E L Otto11, Francesco Ragone13,20, Sonia I. Seneviratne6, Roop K. Singh7, Amalie Skålevåg1, Piet Termonia13,19, Lisa Thalheimer11, Maarten van Aalst7,8,21, Joris Van den ergh13, Hans Van de Vyver13, Stéphane Vannitsem13, Geert Jan van Oldenborgh2,3, Bert Van Schaeybroeck13, Robert Vautard5, Demi Vonk8, Niko Wanders";
let substitution = "\\g<1>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}