#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/www\.chytryhonza\.cz\/(hypoteka|americka-hypoteka|refinancovani-hypoteky).*"
Local $sString = "https://www.chytryhonza.cz/hypotecni-kalkulacka?v=iTBDcj1Zi0eb4mSEPe3k3CNWhpqvaZmAyRTmCq%2Be1j085RJkWNTwLmXX8mRWLjvUDUxgpyVpx0VS0q08qi%2FTIvRBMeiXW4w9fK%2F8cQg4wXlsDubtLGXAdytQCNC2LTfF" & @CRLF & _
"https://www.chytryhonza.cz/hypotecni-kalkulacka?v=" & @CRLF & _
"https://www.chytryhonza.cz/srovnavac" & @CRLF & _
"https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=dd" & @CRLF & _
"https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=1qC3j5r%2BHim0K68IAcodRMrYv6ikx0NneJC39H2oOdl2H8QZ5DL9glGwRtkQSV%2BhVT0c%2B95YLTSmA4BDugvpUQkWIDUmTmv4rcg1t78EMid9jhDOoHh%2BXxRZAxYBGKkB" & @CRLF & _
"" & @CRLF & _
"https://www.chytryhonza.cz/hypoteka" & @CRLF & _
"https://www.chytryhonza.cz/hypoteka#aca30160bd78b" & @CRLF & _
"https://www.chytryhonza.cz/americka-hypoteka" & @CRLF & _
"https://www.chytryhonza.cz/refinancovani-hypoteky" & @CRLF & _
"https://www.chytryhonza.cz/zivot" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")