import Foundation
let pattern = #"(?<CCT>(?:(?<=[A-Z])(?=[^A-Z]))|(?:(?<=[a-z])(?=[^a-z]))|(?:(?<=\d)(?=\D))|(?:(?<=[^A-Za-z\d])(?=[A-Za-z\d])))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"this regex matches all transitions. 1nur15itmightb3interest1ng"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)