#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(?:" & @CRLF & _
" (?<!\S)@ # Match "@" only if it's not preceded by a non-whitespace character" & @CRLF & _
" | # OR" & @CRLF & _
" (?:" & @CRLF & _
" # Telegram link types reference: https://core.telegram.org/api/links" & @CRLF & _
" #" & @CRLF & _
" (?:https?://)? # Optional HTTP or HTTPS protocol" & @CRLF & _
" (?:www\.)? # www subdomain" & @CRLF & _
" (?:t\.me|telegram\.(?:me|dog)) # Match "t.me", "telegram.me", or "telegram.dog" domains" & @CRLF & _
" / # Ensure a forward slash after the domain" & @CRLF & _
" | # OR" & @CRLF & _
" tg://resolve\?domain= # Match Telegram deep link schema (tg://resolve?domain=)" & @CRLF & _
" )" & @CRLF & _
" | # OR" & @CRLF & _
" (?=\b # Positive lookahead: Ensure a valid subdomain before username" & @CRLF & _
" (?!\w*__) # Disallow double underscores anywhere in the username" & @CRLF & _
" (?!\w*_{2,}) # Disallow underscores at the start or end of username" & @CRLF & _
" (?:[a-z][a-z0-9_]{3,31}) # Username" & @CRLF & _
" (?<!_) # Disallow usernames ending with an underscore" & @CRLF & _
" \.t\.me$ # Ensure it ends with ".t.me"" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"(?P<username> # Start capturing the username" & @CRLF & _
" (?!\w*_{2,}) # Disallow double underscores in the username" & @CRLF & _
" (?!\w*[^0-9a-z_.,\s]) # Ensure valid characters (letters, numbers, underscores, dots, commas, spaces)" & @CRLF & _
" (?:[a-z][a-z0-9_]{3,31}) # Username" & @CRLF & _
" (?<!_) # Disallow username ending with an underscore" & @CRLF & _
" \b # Ensure it's a valid word boundary" & @CRLF & _
")" & @CRLF & _
"(?:\.t\.me)? # Optional ".t.me" subdomain"
Local $sString = "@username" & @CRLF & _
"@user_name" & @CRLF & _
"@username123" & @CRLF & _
"@alanbadoev @orkester okinea.t.me" & @CRLF & _
"@username123_, @username123" & @CRLF & _
"@username123, @username123_" & @CRLF & _
"@username123, username123.t.me" & @CRLF & _
"@name_with_underscore" & @CRLF & _
"@user$name" & @CRLF & _
"@user__name" & @CRLF & _
"@username_" & @CRLF & _
"@user name" & @CRLF & _
"@toolongusernameeeeeeeeeeeeeeeeeee" & @CRLF & _
"@123username" & @CRLF & _
"https://t.me/username" & @CRLF & _
"https://www.t.me/username" & @CRLF & _
"http://t.me/username" & @CRLF & _
"t.me/username" & @CRLF & _
"tg://resolve?domain=username" & @CRLF & _
"username.t.me" & @CRLF & _
" username.t.me" & @CRLF & _
"https://t.me/@username" & @CRLF & _
"http://t.me/user__name" & @CRLF & _
"username_.t.me" & @CRLF & _
"user__name.t.me" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")