$re = '/^\d{2}-[A-Z]\d-\d{5}$/m';
$str = '98-B3-10478';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);