const regex = /(?P<reference_sequence>(NM|NR|XM|XR)_[0-9]{4,12}|ENST[0-9]{1,11})(\.(?P<version>([0-9]?[0-9])))?(:(?P<prefix>c|n)\.(?P<start>-?[1-9][0-9]{0,7})(?P<start_offset>[+-][1-9][0-9]{0,7})?(?P<ref>[ACTG])>(?P<alt>[ACTG]))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<reference_sequence>(NM|NR|XM|XR)_[0-9]{4,12}|ENST[0-9]{1,11})(\\.(?P<version>([0-9]?[0-9])))?(:(?P<prefix>c|n)\\.(?P<start>-?[1-9][0-9]{0,7})(?P<start_offset>[+-][1-9][0-9]{0,7})?(?P<ref>[ACTG])>(?P<alt>[ACTG]))?', 'gm')
const str = `NM_12345.5:c.1999+500C>A
NR_12345.5:c.1999+500C>A
XM_12345.5:c.1999+500C>A
XR_12345.5:c.1999+500C>A
ENST12334455677:c.1999+500C>A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}