import Foundation
let pattern = #"^(\[WIP\])?(\[PIDSS-\d+]) [[:upper:]].{3,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[PIDSS-12345] Blah blah
[PIDSS-1] Blah blah
[PIDSS-] Blah blah
^(?![A-Z]).+$
[WIP][PIDSS-1] Blah blah
[WIP]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)