$re = '/(\b[A-Z]\w*\s*)+/m';
$str = 'Test This String Out Here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);