# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=START)(?s)(.*?)(?=Closing)"
test_str = ("more useless gibberish at the begininng...\n"
"separated by new lines...\n\n"
"START Fund Class Fund Number Fund Currency\n"
"XYZ XYZ XYZ USD\n\n"
" bunch of text with lots of newlines in between... Closing 11.11 1,111.11 111,111.11\n\n"
"more useless gibberish between the groups...\n"
"separated by new lines...\n\n"
"START Fund Class Fund Number Fund Currency\n"
"XYZ XYZ XYZ USD\n\n"
"The word START appears in the middle sometimes multiple times, but it's fine bunch of text with lots of newlines in between... Closing 22.22 2,222.22 222,222.22\n\n"
"more useless gibberish at the end...\n"
"separated by new lines...")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.