re = /(?<phone>(\+?\d{1,4}?[-.\s]?)?(\(\d{1,4}?\))?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9})|(?<email>[\w\-][\w\-\.]+@[\w\-][\w\-\.]+[a-zA-Z]{1,4})/i
str = 'My email address is email@domain.com and my phone number is +919999999999 my other email address is email1@domain.com and my phone number is +912012345678 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end