#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<exe>npm)?\ ?(?<run>(?<=\k<exe> )run(?:-script)?)?\ ?(?<command>(?<=\k<run> )[a-z]+(?:[-|:|.|_][a-z]+)?|(?<!\k<run> )[a-z]+(?:[-][a-z]+)?)?\ ?(?<pkgdetails>[a-z0-9\>\=\:\+\#\^\.\@\/][a-z0-9\>\=\:\+\#\^\~\.\@\/\-]+)?\ ?(?<options>(?:\ [-]{1,2}[a-zA-Z]+(?:[-][a-z]+)*)*)?$"
Local $sString = "npm install cordova-browser@~5.0.1 --production --save" & @CRLF & _
"" & @CRLF & _
"npm install --no-package-lock" & @CRLF & _
"npm -v" & @CRLF & _
"" & @CRLF & _
"npm version major" & @CRLF & _
"npm version minor" & @CRLF & _
"npm version patch" & @CRLF & _
"" & @CRLF & _
"npm run build" & @CRLF & _
"npm run build:spypkg" & @CRLF & _
"npm run build-spypkg" & @CRLF & _
"npm run build.spypkg" & @CRLF & _
"npm run build_spypkg" & @CRLF & _
"npm run-script build:spypkg" & @CRLF & _
"npm run-script build-spypkg" & @CRLF & _
"npm run-script build.spypkg" & @CRLF & _
"npm run-script build_spypkg" & @CRLF & _
"" & @CRLF & _
"i sots --D" & @CRLF & _
"i sots --production" & @CRLF & _
"i sots --production --no-save" & @CRLF & _
"install sots --production --no-save" & @CRLF & _
"npm install sots --production --no-save" & @CRLF & _
"" & @CRLF & _
"npm install ./package.tgz" & @CRLF & _
"npm install https://github.com/indexzero/forever/tarball/v0.5.6" & @CRLF & _
"npm install sax" & @CRLF & _
"npm install sax -P" & @CRLF & _
"npm install sax -D" & @CRLF & _
"npm install sax -O" & @CRLF & _
"" & @CRLF & _
"i" & @CRLF & _
"" & @CRLF & _
"npm i" & @CRLF & _
"i sax" & @CRLF & _
"i sax -D" & @CRLF & _
"install" & @CRLF & _
"install sax -P" & @CRLF & _
"install sax -D" & @CRLF & _
"install sax -O" & @CRLF & _
"npm install githubname/reponame" & @CRLF & _
"npm install @myorg/privatepackage" & @CRLF & _
"npm install node-tap --save-dev" & @CRLF & _
"npm install dtrace-provider --save-optional" & @CRLF & _
"npm install readable-stream --save-exact" & @CRLF & _
"npm install ansi-regex --save-bundle" & @CRLF & _
"npm install sax@latest" & @CRLF & _
"npm install @myorg/mypackage@latest" & @CRLF & _
"npm install sax@0.1.1" & @CRLF & _
"npm install @myorg/privatepackage@1.5.0" & @CRLF & _
"npm install sax@">=0.1.0 <0.2.0"" & @CRLF & _
"npm install @myorg/privatepackage@">=0.1.0 <0.2.0"" & @CRLF & _
"npm install git+ssh://git@github.com:npm/cli.git#v1.0.27" & @CRLF & _
"npm install git+ssh://git@github.com:npm/cli#semver:^5.0" & @CRLF & _
"npm install git+https://isaacs@github.com/npm/cli.git" & @CRLF & _
"npm install git://github.com/npm/cli.git#v1.0.27" & @CRLF & _
"npm install mygithubuser/myproject" & @CRLF & _
"npm install github:mygithubuser/myproject" & @CRLF & _
"npm install gist:101a11beef" & @CRLF & _
"npm install bitbucket:mybitbucketuser/myproject" & @CRLF & _
"npm install gitlab:mygitlabuser/myproject" & @CRLF & _
"npm install gitlab:myusr/myproj#semver:^5.0" & @CRLF & _
"npm install sax@">=0.1.0 <0.2.0" bench supervisor" & @CRLF & _
"npm install sax --force"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")