$re = '/#[0-9a-f]{3}(?:[0-9a-f]{3})?(?=\W|$)/m';
$str = '#ffffff
#fff#fff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);