$re = '/^[\u0E01-\u0E2E]+$/';
$str = 'ฟก';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);