$re = '/^```([\w]*)\n(.*\n)```/m';
$str = '```dsgaDASF
fas
```
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);