$re = '/[0-9]{3} ?[0-9]{2}/';
$str = '102 00 12000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);