import Foundation
let pattern = #"(?=\b\d{8}\b)(?:(?:9?8?7?6?5?4?3?2?1?0?)|(?:0?1?2?3?4?5?6?7?8?9?))(?<=\d{8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This regex is to match Ascending or descending order of 8 digit number
01234567 0 to 7
12345678 1 to 8
23456789 2 to 9
12456789 missing 3
01236789 missing 4,5
23456789 missing 0,1
1234567
12345
012345678
123456789
0123456789
98765432 9 to 2
87654321 8 to 1
76543210 7 to 0
98765321 missing 4
96543210 missing 7,8
98765432 missing 0,1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)