import Foundation
let pattern = #"(?<=Greg)(.*)(?=hits)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Greg Wylde hits the penalty kick with his left foot to the lower left corner and scores!!
Craig Slater hits the penalty kick with his right foot to the upper right corner and scores!!
Aleksei Eremenko hits the penalty kick with his right foot to the lower left corner and scores!!
Matty Taylor powers the penalty kick with his right foot to the lower right corner and scores!! The goalkeeper was nowhere near the shot.
Craig Reid places the penalty kick with his right foot to the upper left corner and scores!! The goalkeeper guessed correctly but could not stop the shot.
Robbie Simpson hits the penalty kick with his right foot to the lower right corner and the goalkeepper saves it!
Chris Martin hits the penalty kick with his right foot to the lower right corner and scores!!
Peter Vincenti hits the penalty kick with his right foot to the lower right corner and scores!!
Michael Smith hits the penalty kick with his right foot to the lower right corner and the goalkeepper saves it!
Marcus Tudgay hits the penalty kick with his right foot high through the middle and the goalkeepper saves it!
Jack Redshaw hits the penalty kick with his right foot and hits the crossbar. What a missed chance!
Adam Chapman hits the penalty kick with his right foot to the lower right corner and scores!!
Adam Rooney hits the penalty kick with his right foot to the lower left corner and scores!!
Eoin Doyle hits the penalty kick with his right foot to the lower right corner and scores!!
Eidur Gudjohnsen hits the penalty kick with his right foot to the upper left corner and scores!!
Rodolph Austin hits the penalty kick with his right foot to the lower right corner and scores!!
Aleksei Eremenko hits the penalty kick with his right foot to the lower left corner and scores!!
Conor Hourihane hits the penalty kick with his left foot to the lower left corner and scores!!
Ian Henderson hits the penalty kick with his right foot and hits the crossbar. What a missed chance!
Izale McLeod hits the penalty kick with his right foot to the lower right corner and scores!!
Nicholas Ajose hits the penalty kick with his right foot to the lower left corner and scores!!
Patrick Madden hits the penalty kick with his right foot to the lower left corner and scores!!
Simon Walton hits the penalty kick with his right foot to the lower left corner and scores!!
Will Evans powers the penalty kick with his right foot and sends it over the crossbar. What a missed chance!
Jack Midson powers the penalty kick with his right foot to the lower right corner and the goalkeepper saves it!
Brian Howard places the penalty kick with his left foot low through the middle and the goalkeepper saves it!
Andrew Williams hits the penalty kick with his right foot to the lower right corner and scores!!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)