$re = '/^\d*[a-zA-Z]{1,}\d*/m';
$str = '2342**+5665..34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);