$re = '/^[\w!#$%&\'*+\-\=?\^_`{|}~]+(\.[\w!#$%&\'*+\-\?\^_`{|}~]+)*@((([\-\w]+\.)+[a-zA-Z]{2,4})|(([0-9]{1,3}\.){3}[0-9]{1,3}))$/m';
$str = 'antonio.pz@outlook.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);