using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<log_time>[\dT\-\:]+)\s+(?P<log_host>[\w\-]+)(?:\.[\w\-\.]*\s+|\s+)(?P<log_type>\w+)\s+(?:(?=\()\((?P<log_module>[^\)]+)\)\s+|)(?:(?=\[)\[(?P<log_tenant>[^ ]+)\]\s+|)(?P<log_message>.+)";
string input = @"2017-10-18T12:30:00-04:00 machine.domain.net INFO (Timer-24) [12@MACHINE;;] com.vmware.horizon.connector.admin.StateService - Saving state config to disk DONE.
2017-10-18T12:30:02-04:00 machine.domain.net INFO (Timer-12) [2@MACHINE;;] com.vmware.horizon.dirsync.SyncController - ========== BEGIN SYNC [LIVE RUN] ==========
2017-10-18T12:31:19-04:00 machine INFO pkinit[3753]: closing down fd 12
2017-10-17T15:55:32-04:00 machine.domain.net INFO (SimpleAsync TaskExecutor-2052) [2@MACHINE;;] com.vmware.horizon.connector.utils.RestClient - END sendRequestBase (https://workspaceone.domain.net/SAAS/t/MACHINE/jersey/manager/api/connectormanagement/connectors/11111111-2222-3333-4444-555555555555/syncalerts, ..., application/vnd.vmware.horizon.manager.connector.directory.sync.alerts+json, POST, null, ...)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}