using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\\|/]*[.mp3]+$";
string input = @"D:\Users\JohnDoe\Desktop\Node.JS-MP3-converter\mp3\kick_(1).mp3
D:\Users\JohnDoe\Desktop\Node.JS-MP3-converter\mp3/kick_(1).mp3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}