package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\{([^}]+)\}`)
var str = `Hello ${world}. {This is} the ${apple}. You ${may} find the gravity`
var substitution = "test"
fmt.Println(re.ReplaceAllString(str, substitution))
}