$re = '/\S+\[v=\"(standard)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+\/(returns|mpt_statistics)\/\w+\/(\w+)\/(\w+)/';
$str = 'root/4-825-ReturnAndStatsCompositeAPI[v="standard-return",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/share_classes/array[3]/returns/maximum_offering_price/cumulative/one_day
root/4-825-ReturnAndStatsCompositeAPI[v="standard-return",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/share_classes/array[3]/mpt_statistics/absolute/gross/one_year/sharpe_ratio
root/6-825-ReturnAndStatsCompositeAPI[v="standard-benchmark",g="mostRecent",p="{"asOfDate":""}"]/data/share_classes/array[0]/benchmark_types/benchmark_types_breakdown/array[3]/returns/net/cumulative/three_year
root/6-825-ReturnAndStatsCompositeAPI[v="standard-benchmark",g="mostRecent",p="{"asOfDate":""}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics/absolute/net/one_year/skewness
root/7-825-ReturnAndStatsCompositeAPI[v="standard-index",g="mostRecent",p="{"asOfDate":""}"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns/net/annualized/ten_year
root/1-825-ReturnAndStatsCompositeAPI[v="standard-category",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/share_classes/array[1]/peer_categories/morningstar_category/returns/net/cumulative/fifty_two_week
root/12-825-ReturnAndStatsCompositeAPI[v="timeSeries-return",g="timeSeries",p="{"rollingPeriod":"1Y","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);