import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)(\\d+)\\s(st(u?)k?)s?|(p((ie)?ce(s?)))";
final String string = "apple 10m\n"
+ "10mm\n"
+ "11ml\n"
+ "11kg\n"
+ "12g\n"
+ "13gr\n"
+ "14m3\n"
+ "15m2\n\n"
+ "apple 10 stuks \n"
+ "10 pieces\n"
+ "11 pces\n"
+ "11 pce\n"
+ "12 stk\n"
+ "13 stuks\n"
+ "14m3\n"
+ "15m2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}