package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<name>[A-ZÀ-Ÿ\s-\.\/\(\)'\/]+)(?:\s)*(?P<dosage>(?:[\d\s]+(?:ml|ML|mg|MG|g|%)*[\s/]*)*)(?:\s)(?P<adminmode2>[A-ZÀ-Ÿ\s-\.\/\(\)'\/]*)(?P<separator>,|\.\s\/)(?:\s)(?P<adminmode1>[a-zA-ZÀ-ÿ\s\(\)\-'\.0-9]+)`)
var str = `CALMANTE VITAMINADO PEREZGIMENEZ COMPRIMIDOS , 200 comprimidos`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}