use strict;
my $str = 'Table 1. Coefficients for the polynomial expansion equations. Standard deviations (see introduction):
σ = 5.5832 x 10-1 (low temperature range), σc,w = (4.8307 x 10-1 combined temperature ranges, weighted),
σc,uw = 3.4016 x 10-1 (combined temperature ranges, unweighted)
T = 176.15 to 400.00 K T = 400.00 to 512.64 K Coefficient
ρ = A + BT + CT 2 + DT 3 + … ρ = [1 + 1.75(1 - T/Tc)1/3 + 0.75(1 - T/Tc)]
[ρc + A(Tc -T ) + B(Tc - T )2 + C(Tc - T )3 + D(Tc - T )4]';
my $regex = qr/T\s?=\s?-?\d+\.\d+\s?to\s?\d+\.\d+\s?K/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}