import Foundation
let pattern = #"(\d\d) (\w\w) (.*?) (Sim|Não)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"01 AC ACRE Sim 02 AL ALAGOAS Não 03 AP AMAPÁ Sim 04 AM AMAZONAS Sim 05 BA BAHIA Não 06 CE CEARÁ Não 07 DF DISTRITO FEDERAL Não 08 ES ESPÍRITO SANTO Não 10 GO GOIÁS Não 12 MA MARANHÃO Não 13 MT MATO GROSSO Não 28 MS MATO GROSSO DO SUL Não 14 MG MINAS GERAIS Não 15 PA PARÁ Não 16 PB PARAÍBA Não 17 PR PARANÁ Não 18 PE PERNAMBUCO Não 19 PI PIAUÍ Não 22 RJ RIO DE JANEIRO Não 20 RN RIO GRANDE DO NORTE Não 21 RS RIO GRANDE DO SUL Não 23 RO RONDÔNIA Sim 24 RR RORAIMA Sim 25 SC SANTA CATARINA Não 26 SP SÃO PAULO Não 27 SE SERGIPE Não 29 TO TOCANTINS Não "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"case "\2": _UF = "\1";\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)