const regex = /(?=(\d{2}$)+(?!\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(\\d{2}$)+(?!\\d))', 'gm')
const str = `11,11
00,00
20,20
20.20
30.233
1000000000000000
123123
12432`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);