$re = '/(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[$*&@#])[\w $*&@#]{8,}/m';
$str = 'Osas@123aaaa
mamuteasd
mamute123
12325245345
@xXforgid123a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);