#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^.*?(consolidation of).*?(\d+(\.\d+)?).*?(into).*?(\d+(\.\d+)?).*?$"
Local $sString = "STERLING PROGRESS BERHAD ("SPB" OR THE "COMPANY") SHARE CONSOLIDATION OF EVERY FOUR (4) ORDINARY SHARES OF RM0.025 EACH IN SPB INTO ONE (1) NEW ORDINARY SHARE OF RM0.100 EACH IN SPB ("SPB SHARE" OR "SHARE") ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 8 FEBRUARY 2017 ("ENTITLEMENT DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"Consolidation of every twenty (20) ordinary shares of RM0.005 each in Hubline Berhad ("Hubline") into one (1) ordinary shares of RM0.10 in each in Hubline ("Consolidated Shares") ("Share Consolidation")" & @CRLF & _
"ENTITLEMENT DATE FOR THE CONSOLIDATION OF EVERY TWO (2) ORDINARY SHARES IN MTOUCHE TECHNOLOGY BERHAD ("MTOUCHE" OR THE "COMPANY") ("SHARES") INTO ONE (1) SHARE ("CONSOLIDATED SHARES") AT 5.00 P.M. ON 24 MARCH 2017 ("SHARE CONSOLIDATION") ("SHARE CONSOLIDATION ENTITLEMENT DATE")" & @CRLF & _
"Consolidation of every five (5) ordinary shares in Sinotop Holdings Berhad ("Sinotop") into one (1) new ordinary share in Sinotop ("Consolidated Share") after the capital reduction and repayment ("Share Consolidation")" & @CRLF & _
"BOOKS CLOSURE DATE FOR THE CONSOLIDATION OF EVERY FOUR (4) ORDINARY SHARES OF USD0.01 EACH IN XIDELANG HOLDINGS LTD ("XDL" OR THE "COMPANY") INTO ONE (1) ORDINARY SHARE OF USD0.04 ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 17 MAY 2017 ("SHARE CONSOLIDATION") ("BOOKS CLOSURE DATE")" & @CRLF & _
"ADJUSTMENTS TO THE NUMBER AND EXERCISE PRICE OF OUTSTANDING 2015/2018 ("WARRANTS C") AS SPECIFIED IN THE DEED POLL DATED 17 JUNE 2015 (AS VARIED AND AMENDED BY A SUPPLEMENTAL DEED POLL DATED 27 APRIL 2016) ("DEED POLL C") ("ADJUSTMENTS"), AS A CONSEQUENCE OF THE CONSOLIDATION OF EVERY FOUR (4) ORDINARY SHARES OF USD0.01 EACH IN XIDELANG HOLDINGS LTD ("XDL" OR THE "COMPANY") ("XDL SHARES" OR "SHARES") INTO ONE (1) SHARE AT 5.00 P.M. ON 17 MAY 2017 ("BOOKS CLOSURE DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"BOOKS CLOSURE DATE FOR THE CONSOLIDATION OF EVERY 3 ORDINARY SHARES IN ASIA BIOENERGY TECHNOLOGIES BERHAD ("ABT" OR THE "COMPANY") ("SHARES") INTO 1 SHARE ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 5 JUNE 2017 ("SHARE CONSOLIDATION") ("BOOKS CLOSURE DATE")" & @CRLF & _
"ADJUSTMENTS TO THE NUMBER AND EXERCISE PRICE OF OUTSTANDING 2014/2024 ("WARRANTS A") AS SPECIFIED IN THE DEED POLL CONSTITUTING THE WARRANTS A DATED 17 MARCH 2014 ("DEED POLL A") ("ADJUSTMENTS") ARISING FROM THE CONSOLIDATION OF EVERY 3 ORDINARY SHARES IN ASIA BIOENERGY TECHNOLOGIES BERHAD ("ABT" OR THE "COMPANY") ("SHARES") INTO 1 SHARE ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 5 JUNE 2017 ("SHARE CONSOLIDATION") ("BOOKS CLOSURE DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"Share consolidation involving the consolidation of every 10 existing ordinary shares in Mulpha International Bhd ("Mulpha") into 1 ordinary share in Mulpha ("Consolidated Share(s)") ("Share Consolidation")" & @CRLF & _
"MMAG HOLDINGS BERHAD ("MMAG" OR THE "COMPANY") SHARE CONSOLIDATION OF EVERY 4 ORDINARY SHARES IN MMAG INTO 1 NEW ORDINARY SHARE IN MMAG ("MMAG SHARE" OR "SHARE") ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 12 JULY 2017 ("ENTITLEMENT DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"SHARE CONSOLIDATION OF EVERY 4 ORDINARY SHARES IN SMTRACK BERHAD ("SMTRACK" OR "COMPANY") INTO 1 NEW ORDINARY SHARE IN SMTRACK ("SMTRACK SHARE") ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 8 AUGUST 2017 ("ENTITLEMENT DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"BOOKS CLOSURE DATE FOR THE CONSOLIDATION OF EVERY 3 ORDINARY SHARES IN SANICHI TECHNOLOGY BERHAD ("SANICHI" OR THE "COMPANY") ("SHARES") INTO 1 SHARE ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 6 SEPTEMBER 2017 ("SHARE CONSOLIDATION") ("BOOKS CLOSURE DATE")" & @CRLF & _
"BOOKS CLOSURE DATE FOR THE CONSOLIDATION OF EVERY 4 ORDINARY SHARES IN KEY ALLIANCE GROUP BERHAD ("KAG" OR THE "COMPANY") ("SHARES") INTO 1 SHARE ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 14 SEPTEMBER 2017 ("SHARE CONSOLIDATION") ("BOOKS CLOSURE DATE")" & @CRLF & _
"BOOKS CLOSURE DATE FOR THE CONSOLIDATION OF EVERY 3 ORDINARY SHARES IN AT SYSTEMATIZATION BERHAD ("ATS" OR THE "COMPANY") ("SHARES") INTO 1 SHARE ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 14 SEPTEMBER 2017 ("SHARE CONSOLIDATION") ("BOOKS CLOSURE DATE")" & @CRLF & _
"CONSOLIDATION OF EVERY 4 ORDINARY SHARES IN PDZ HOLDINGS BHD ("PDZ" OR THE "COMPANY") ("PDZ SHARES" OR "SHARES") HELD AT 5.00 P.M. ON 4 DECEMBER 2017 ("ENTITLEMENT DATE") INTO 1 PDZ SHARE ("CONSOLIDATED SHARE") ("SHARE CONSOLIDATION")" & @CRLF & _
"Share consolidation involving the consolidation of every 3 existing ordinary shares in Chemical Company of Malaysia Berhad ("CCMB" or "Company") into 1 ordinary share in CCMB ("CCMB Consolidated Share(s)") ("Share Consolidation")" & @CRLF & _
"PARLO BERHAD ("PARLO" OR THE "COMPANY") CONSOLIDATION OF 10 ORDINARY SHARES IN PARLO INTO 1 NEW ORDINARY SHARE IN PARLO ("PARLO SHARE" OR "SHARE") ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 28 DECEMBER 2017 ("ENTITLEMENT DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"Consolidation of every 2 existing ordinary shares in the share capital of Scomi Group Bhd ("Scomi") into 1 ordinary share in the share capital of Scomi ("Consolidated Share") ("Share Consolidation")" & @CRLF & _
"ENTITLEMENT DATE FOR THE DISTRIBUTION OF THE ENTIRE SHAREHOLDINGS IN AFFIN BANK BERHAD ("AFFIN BANK") HELD BY AFFIN HOLDINGS BERHAD ("AFFIN") TO THE ENTITLED SHAREHOLDERS OF AFFIN WHOSE NAMES APPEAR IN AFFIN'S RECORD OF DEPOSITORS BY WAY OF A DISTRIBUTION-IN-SPECIE VIA A REDUCTION OF THE ENTIRE CONSOLIDATED CAPITAL AND THE RETAINED PROFITS OF AFFIN ("DISTRIBUTION")" & @CRLF & _
"Merger of Scomi Engineering Bhd with Scomi Group Bhd ("Scomi") undertaken by way of a members scheme of arrangement pursuant to Section 366 of the Companies Act, 2016. Scomi shall pay the Offer Price of RM0.300 per Scomi Engineering Scheme Share which shall be satisfied entirely via: (a) a share swap where for every 7 Scomi Engineering Scheme Shares held by Scheme Shareholders, 10 new Consolidated Shares shall be issued at the Issue Price, and (b) the issuance of 1 Warrant for every 10 Consideration Shares issued." & @CRLF & _
"HO WAH GENTING BERHAD ("HWGB" OR THE "COMPANY") CONSOLIDATION OF 4 ORDINARY SHARES IN HWGB INTO 1 NEW ORDINARY SHARE IN HWGB ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 7 MARCH 2018 ("ENTITLEMENT DATE") ("SHARE CONSOLIDATION")" & @CRLF & _
"TIGER SYNERGY BERHAD ("TSB" OR "COMPANY") SHARE CONSOLIDATION OF EVERY 4 EXISTING ORDINARY SHARES IN TSB ("TSB SHARES" OR "SHARES") INTO 1 NEW TSB SHARE ("CONSOLIDATED SHARE") AT 5.00 P.M. ON 5 JUNE 2018 ("ENTITLEMENT DATE") ("SHARE CONSOLIDATION")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")