// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?P<Root>file\:\/\/\/(?:[A-Za-z]+):(?:\/|\\)|https\:\/\/)(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:pdf)))$"#).unwrap();
let string = "file:///D:/Documents/My%20Documents/T09_27jun-17jul_V_Fro.pdf
file:///z:/Documents/My%20Documents/pdfs/eggs,%20milk,%20fruit.pdf
file:///zz:/Documents/My%20Documents/example.folder/icebreaker.pdf
file:///abv:/program%20shmogram%20(x86)/CoolTheVideoGameTheMovie/lewd.mods/uwuDialogueforFemales.pdf
file:///h:/Documents/My%20Documents/example.folder/New%20folder/ExamplE%20folder%203/very_cool_kanye.pdf
https://www.samsclub.com/savings/20230626/T09_27jun-17jul_V_Fro.pdf
https://whatkindofprefixisthis.RobertTheWebsite.io/AboutUs/Who-Da-frick_IS_Robert-anyways.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}