package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([1-9]|[12][0-9]|3[0])\b`)
var str = `1 01 12 20 31 32 34 998
2
3
4
5
6
7
8
9
10
11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}