import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?([2-9][0-8][0-9])";
final String string = "1234567890\n"
+ "99999999999999\n"
+ "hello world1234567890\n"
+ "123-456-7890\n"
+ "0123456789\n"
+ "123.456.7890\n"
+ "123 456 7890\n"
+ "8054448445\n"
+ "3104448445\n"
+ "8187558094\n"
+ "310 \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}