package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:[0-9]+,{1}?)+[0-9]+)$`)
var str = `1234,1234,1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}