$re = '/Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never/m';
$str = 'GigabitEthernet0/2 is down, line protocol is down (notconnect)
Last input never, output never, output hang never
GigabitEthernet0/3 is down, line protocol is down (notconnect)
GigabitEthernet0/4 is down, line protocol is down (notconnect)
Last input 23w0d, output 23w0d, output hang never
GigabitEthernet0/5 is down, line protocol is down (notconnect)
Last input 23w0d, output 23w0d, output hang never
GigabitEthernet0/6 is down, line protocol is down (notconnect)
Last input 11w5d, output 1w4d, output hang never
Last input 11w5d, output 00:00:01, output hang never
Last input never, output never, output hang never
GigabitEthernet0/12 is down, line protocol is down (notconnect)
Last input never, output never, output hang never
GigabitEthernet0/2 is administratively down, line protocol is down (disabled)
Last input never, output never, output hang never
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);