const regex = /\b(0?[1-9]|[12]\d{1}|3[01]])[\/|\.|-](0?[1-9]|12|11)[\/|\.|-]\d{1,4}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(0?[1-9]|[12]\\d{1}|3[01]])[\\\/|\\.|-](0?[1-9]|12|11)[\\\/|\\.|-]\\d{1,4}\\b', 'g')
const str = `Bắt các chuỗi ngày tháng này
12/01/2017
15/2/2017
3/03/2018
12/24/2018
1.1.2018
7-9-18
1.31.2018
Không bắt các chuỗi như thế này, vì không đúng ngày tháng
123/2/1234 13/ab/3346 12/223/12 60/60/2018 32/12/2018
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}