const regex = /(?:(?:rgb\((\d{1,3}),\s?(\d{1,3}),\s?(\d{1,3})\))|(?:rgba\((\d{1,3}),\s?(\d{1,3}),\s?(\d{1,3}),\s?([0-1]\.0|0\.[0-9])\)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:rgb\\((\\d{1,3}),\\s?(\\d{1,3}),\\s?(\\d{1,3})\\))|(?:rgba\\((\\d{1,3}),\\s?(\\d{1,3}),\\s?(\\d{1,3}),\\s?([0-1]\\.0|0\\.[0-9])\\)))', 'gm')
const str = `rgb(0, 0, 0)
rgb(0,0,0)
rgb(255, 255, 255)
rgba(255, 255, 255, 1)
rgba(255, 255, 255,1)
rgba(255, 255, 255, 0)
rgba(255, 255, 255, 0.9)
rgba(255, 255, 255, 0.0)
rgba(255, 255, 255, 1.0)
rgba(255, 255, 255, 1.1)
rgba(255, 255, 255, 666)
rgba(255, 255, 255ab)
rgb(255, 255, 255, 344)
#p1 {background-color: rgba(255, 0, 0, 0.3);} /* red with opacity */
#p2 {background-color: rgba(0, 255, 0, 0.3);} /* green with opacity */
#p3 {background-color: rgba(0, 0, 255, 0.3);} /* blue with opacity */`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}