using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SQL: \[\d+\] (?<sql>.*) Sent SQL: \[\d+\] (?<send_sql>.*) Params:";
string input = @"SQL: [126] INSERT INTO `tbl_ip_data` (`ip_start`, `ip_end`, `region_id`, `country_id`, `create_at`)
VALUES (:v0d, :v1d, :v2d, :v3d, :v4d) Sent SQL: [163] INSERT INTO `tbl_ip_data` (`ip_start`, `ip_end`, `region_id`, `country_id`, `create_at`)
VALUES ('1900145563', '1900145563', '440118', 'CN', '2022-04-15 21:46:42') Params: 5 Key: Name: [4] :v0d paramno=-1 name=[4] "":v0d"" is_param=1 param_type=2 Key: Name: [4] :v1d paramno=-1 name=[4] "":v1d"" is_param=1 param_type=2 Key: Name: [4] :v2d paramno=-1 name=[4] "":v2d"" is_param=1 param_type=2 Key: Name: [4] :v3d paramno=-1 name=[4] "":v3d"" is_param=1 param_type=2 Key: Name: [4] :v4d paramno=-1 name=[4] "":v4d"" is_param=1 param_type=2 [] []";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}