re = /^(?=.{6})(?=.*[a-z])(?=.*[A-Z])(?=.*[!"'()\[\]*,-.\/:;<>_`{}|~@#$%^&+=]).*$/
str = 'aaaAAA!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end