import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*at \\w+\\.[A-Z] \\(.+\\n([\\s\\S]+\\n)*.*(\\[as realHandler]|<anonymous>)";
final String string = "Error\n"
+ " at Logger._s (/var/user/impl/lib/log.js:7:17)\n"
+ " at Logger.I (/var/user/impl/lib/log.js:26:22)\n"
+ " at getWxContext (/var/user/impl/route.js:136:7)\n"
+ " at route (/var/user/impl/route.js:19:13)\n"
+ " at EventHandler.exports.main [as realHandler] (/var/user/index.js:14:22)\n"
+ " at EventHandler.handle (/var/runtime/node8/bootstrap.js:401:28)\n"
+ " at invoke (/var/runtime/node8/bootstrap.js:204:22)\n"
+ " at Timeout.setTimeout [as _onTimeout] (/var/runtime/node8/bootstrap.js:133:9)\n"
+ " at ontimeout (timers.js:475:11)\n"
+ " at tryOnTimeout (timers.js:310:5)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}