#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[cC][hH]|[lL][lL]|[rR][rR]|[qQ][uU]|[mnñvzsyjhxwMNÑVZSYJHXW]|[fpbtdkgcFPBTDKGC][lrLR]?|[lrLR])?(?:[iuüIUÜ][eaoéáóEAOÉÁÓ][iyuIYU]|[aáAÁ][hH]?[uúUÚ][aáAÁ]|[iuüIUÜ][hH]?[eaoéáóEAOÉÁÓ]|[eaoéáóEAOÉÁÓ][hH]?[iyuIYU]|[iíIÍ][hH]?[uúUÚ]|[uúüUÚÜ][hH]?[iíyIÍY]|[ieaouíéáóúüIEAOUÍÉÁÓÚÜ])(?:(?:(?:(?:[nmNM]|[rR](?![rR]))s?(?![ieaouíéáóúüIEAOUÍÉÁÓÚÜ]))|(?:(?:[mnñvzsyjhxwMNÑVZSYJHXW]|[lL](?![lL]))(?![ieaouíéáóúüIEAOUÍÉÁÓÚÜ]))|(?:(?:[fpbtdkgFPBTDKG]|[cC](?![hH]))(?![lrLR]?[ieaouíéáóúüIEAOUÍÉÁÓÚÜ])))(?!\s|$))?(?:[ndrlsxNDRLSX](?=\s|$))?"
Local $sString = "SÍLABA CV" & @CRLF & _
" casado" & @CRLF & _
" caro" & @CRLF & _
"" & @CRLF & _
"NÚCLEOS VOCÁLICOS" & @CRLF & _
" DIPTONGOS" & @CRLF & _
" ai, au, ei, eu, oi, ou, ui, iu, ia, ua, ie, ue, io, uo" & @CRLF & _
" varió comió diario miel" & @CRLF & _
"" & @CRLF & _
" CON DOS CERRADAS" & @CRLF & _
" distribuido atribuir atribuí" & @CRLF & _
" muy fui rey" & @CRLF & _
" pausa tierra" & @CRLF & _
" ciudad buitre " & @CRLF & _
"" & @CRLF & _
" CON H INTERCALADA" & @CRLF & _
" desahuciar, ahijado" & @CRLF & _
"" & @CRLF & _
" TRIPTONGOS" & @CRLF & _
" santigüeis" & @CRLF & _
" guay guau rey" & @CRLF & _
" haliéutica hioides huaico" & @CRLF & _
"" & @CRLF & _
" AUA" & @CRLF & _
" palauano" & @CRLF & _
" nahuatl cacahuatal" & @CRLF & _
"" & @CRLF & _
" HIATOS NORMATIVOS (DOS CONSONANTES ABIERTAS)" & @CRLF & _
" aorta" & @CRLF & _
" héroe" & @CRLF & _
" almohada" & @CRLF & _
" línea" & @CRLF & _
"" & @CRLF & _
" HIATOS" & @CRLF & _
" tú sabrías, sabías, vosotros sabíais" & @CRLF & _
" raúl oído búho" & @CRLF & _
" tío púa " & @CRLF & _
"" & @CRLF & _
"ATAQUE C+LÍQUIDA" & @CRLF & _
" cromo" & @CRLF & _
" claro" & @CRLF & _
" cabra" & @CRLF & _
" triple" & @CRLF & _
" dígrafos " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CODAS" & @CRLF & _
" silbo" & @CRLF & _
" cansado" & @CRLF & _
" tacto" & @CRLF & _
" texto" & @CRLF & _
" anticiparse" & @CRLF & _
" álbumes" & @CRLF & _
" asfixia" & @CRLF & _
" enloquecer" & @CRLF & _
"" & @CRLF & _
" SUCESIÓN NS MS RS" & @CRLF & _
" transportar" & @CRLF & _
" transacción" & @CRLF & _
" torso" & @CRLF & _
" perspectivas" & @CRLF & _
" samsara " & @CRLF & _
"" & @CRLF & _
" CODAS A FINAL DE PALABRA" & @CRLF & _
" hablan hablar hablad" & @CRLF & _
" riel rieles" & @CRLF & _
" sílex" & @CRLF & _
" recto" & @CRLF & _
"" & @CRLF & _
"DÍGRAFOS" & @CRLF & _
" chica" & @CRLF & _
" coche" & @CRLF & _
" llave" & @CRLF & _
" calle" & @CRLF & _
" carro" & @CRLF & _
"" & @CRLF & _
"EXTRANJERISMOS" & @CRLF & _
" pícnic" & @CRLF & _
" hámster" & @CRLF & _
" mozzarella" & @CRLF & _
" marketing" & @CRLF & _
" búnker" & @CRLF & _
" sándwich" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")