const regex = /<img.*?src=["|'](.*?)["|']/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*?src=["|\'](.*?)["|\']', 'gm')
const str = `<img src='path/to/image/name.jpg' />
<img src='path/to/image/name.jpg' alt="name here"/><p>test card 22</p>
<img src="path/to/image/name.jpg"/><p>test card 22</p>
<img src="http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage"/><p>test card 22</p>
<img src='http://media.cheggcdn.com/media%2Fd08%2Fd087a4d3-8e4e-4e42-8cf0-2b03238a33ef%2Fimage'/><p>test card 22</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}